Shellshock Güvenlik açığı hakkında

On 26 Eylül 2014, in LINUX, by ender

Değerli müşterimiz,

Linux tabanlı sunucularda “Shellshock” isminde bir güvenlik açığı tespit edilmiştir.

Güvenlik açığı hakkında detaylı bilgi almak için CVE-2014-6271

Tespit

Sunucunuzda bu güvenlik açığının olup olmadığını test etmek için;

– Sunucunuza SSH bağlantısı yapın ve aşağıdaki komutu çalıştırın;

env x='() { :;}; echo GuvenliDegil’ bash -c “echo Sunucunuz”

Eğer sunucunuzda güvenlik açığı varsa komutun çıktısı;

GuvenliDegil
Sunucunuz

şeklinde olacaktır.

Sunucunuzda güvenlik açığı yoksa, komutun çıktısı aşağıdaki gibi olacaktır;

bash: warning: x: ignoring function definition attempt
bash: error importing function definition for `x’
Sunucunuz

Çözüm

Güncellemeyi uyguladıktan sonra, yukarıdaki tespit yöntemi ile tekrar test etmelisiniz.

a) Centos işletim sistemi için;

yum update bash komutu ile güncelleme yapabilirsiniz, yada;

– cat /etc/redhat-release komutu ile işletim sistemi versiyonunuza bakın

– uname -a komutu ile işletim sisteminin 32 / 64 bit kontrolünü yapın ve aldığınız bilgilere göre, aşağıda sizin için uygun olan paketi yükleyin;

Centos 6 64bit

rpm -Uvh http://mirror.centos.org/centos-6/6/updates/x86_64/Packages/bash-4.1.2-15.el6_5.1.x86_64.rpm

Centos 5 64bit

rpm -Uvh http://mirror.centos.org/centos-5/5.10/updates/x86_64/RPMS/bash-3.2-33.el5.1.x86_64.rpm

Centos 5 32bit

rpm -Uvh http://mirror.centos.org/centos-5/5.10/updates/i386/RPMS/bash-3.2-33.el5.1.i386.rpm

b) Cloud Linux Kernel işletim sistemi için;

yum clean all
yum update bash

c) Debian işletim sistemi için;

apt-get update
apt-get install –only-upgrade bash

d) Ubuntu işletim sistemi için;

sudo apt-get update && sudo apt-get install bash

 

Comments are closed.